NVAPI Reference Documentation

NVWMI v2.7 API Reference Documentation
NVIDIA
April
2012
  • Main Page
  • Related Pages
  • Classes

Programmer's Guide

2.7

Copyright(c) 2010-2011 NVIDIA Corporation. All rights reserved.

  • Introduction
  • Cooler and Thermal Events
  • NVIDIA Performance Counters
  • Using NVWMI
    • Logging and tracing NVWMI activity
    • Using NVWMI with the WMIC tool

Introduction

1. General Purpose

NVWMI provider allows WMI clients to query and to monitor parameters of NVIDIA hardware. It is implemented as a decoupled WMI provider in a system service (nvwmi.exe in 32-bit or nvwmi64.exe in 64-bit flavors of Windows).

2. General Requirements

  • NVIDIA hardware
  • operational NVIDIA display driver
  • installed NVWMI provider

3. Version-specific Implementation Details

Version 1.2
  • Version 1.2 implements access to physical GPUs' thermal environment and provides basic information such as GPU and board names.
  • Clients could monitor events from GPU coolers and thermal probes. Hardware that is capable of reporting this information is required.
  • Version 1.2 doesn't support WQL queries and doesn't expose methods to modify current configuration. All properties are read-only.

Version 2.0

  • Version 2.0 implements basic WQL support. Complex WQL operators not supported.
  • Version 2.0 implements individual versioning of each MOF class as well as version-reporting of many software and hardware components of a system.
  • Version 2.0 derives most of classes from NamedObject class to allow consistent addressing of objects.

Version 2.1

  • Version 2.1 implements methods for static and dynamic instances.
  • Version 2.1 implements a Board class to simplify diagnostic of multi-GPU and multi-board configurations.
  • Version 2.1 implements many display-related classes - Monitor, DisplaySource, DisplayTarget. Functionality is limited to read-only properties.

Version 2.2

  • Version 2.2 implements several methods to change display parameters:
    • NV::setScaling()
    • DisplaySource::setMode()
    • DisplayTarget::setMode()
    • DisplayTarget::setScaling()
  • Version 2.2 implements addtional properties and dynamic instancing of DisplaySource and DisplayTarget classes.
  • Version 2.2 implements a Mode class which contains basic information about display modes.
  • Version 2.2 improves logging with OS event log support. See Logging and tracing NVWMI activity.

Version 2.3

  • Version 2.3 implements class DisplayGrid with basic support for multi-monitor and Mosaic configurations.
  • Version 2.3 implements additional support for SELECT operator.
  • Version 2.3 improves versioning by adding descriptions into binary version block and OS service records.
  • Version 2.3 implements functionality differentiation between Quadro, NVS and GeForce. GeForce does not support advanced functionality. Note that for mixed configurations (GeForce and Quadro or NVS) functionality is equal to GeForce.
    • Basic classes (Version, NamedObject)
    • NV class is supported (except for NV::setCurrentProfile and NV::setScaling() methods)
    • Gpu class is supported
    • Board class is supported
    • Cooler class is supported
    • ThermalProbe class is supported
    • Event classes are supported (CoolerEvent, ThermalEvent)
    • All other classes are supported only on Quadro and NVS

Version 2.4

  • Version 2.4 implements several methods for defining display grids:
    • NV::createDisplayGridById()
    • NV::createDisplayGridByRef()
    • NV::createDisplayGridByName()
  • Version 2.4 implements OverlapLimits class.
  • Version 2.4 implements several methods of forcing EDID:
    • NV::setEdid()
    • Monitor::setEdid()
  • Version 2.4 implements method for turning Vertical Synchronization (V-sync) on and off - NV::setVsync().
    NOTE: Creating display grids on QuadroPlex is partially supported. Creation of some legitimate display grid configurations straddling more than one GPU might fail.

Version 2.5

  • Version 2.5 implements DisplayGrid::effectiveMode property. It reports bezel-corrected display dimensions while taking into account display grid layout, answering the question "how many unique pixels could you see?". Note that DisplayGrid::currentMode reports per-display video mode.

For example, for horizontal display grid 1x2 (1 row and 2 columns) with each display at 1600x1200 and with overlap -25 for the second display, DisplayGrid::currentMode will be reported as 1600x1200 whereas DisplayGrid::effectiveMode will be 3175x1200. General formula is:
effective size = (per-display size)*(# of display for a given dimension)+(sum of all overlaps for a given dimension)

Version 2.6

  • Version 2.6 implements framework for generic profile support.
  • Version 2.6 implements DisplayPath class and DisplayProfile class with limited functionality.
  • Version 2.6 overhauls display-related classes.
    • Class Monitor renamed to Display
    • Class DisplaySource is deprecated.
    • Class DisplayTarget is deprecated.
    • Methods of DisplayTarget and DisplaySource classes are moved to DisplayGrid and Display.

Version 2.7

  • Version 2.7 implements additional functionality in DisplayProfile class. Following settings are supported:
    • "rows" (32-bit unsigned) ID=0x5822918D, default value is 1
    • "cols" (32-bit unsigned) ID=0x58E21BD4, default value is 1
    • "displayIds" (string with display IDs in hexadecimal notation separated by semicolon ;) ID=0x58B21E43, no default value – current value is always present
    • "overlapCols" (string with overlap values as signed integers, separated by semicolon ;) ID=0x58EB619D, default value is "0"
    • "overlapRows" (string with overlap values as signed integers, separated by semicolon ;) ID=0x58DD36C1, default value is "0"
  • Version 2.7 implements several methods for manipulating display profiles.
    • NV::saveDisplayProfiles()
    • NV::applyDisplayProfiles()
  • Version 2.7 implements several methods for manipulating desktop profiles.
    • NV::loadDesktopProfile()
    • NV::lockDesktopProfile()
  • Version 2.7 supports additional parameters for V-sync control. Method NV::setVsync() accepts following values:
    • 0 Passive
    • 1 Off
    • 2 On
    • 3 Adaptive (refresh rate)
    • 4 Adaptive (half refresh rate)
  • Version 2.7 implements SDI capture driver version as a property of NV class
  • Version 2.7 allows to force EDID on inactive displays

Version 2.8

  • Version 2.8 has revised API. Many classes, their properties and methods are renamed or moved into other classes.
    • update() method is removed from all classes
    • class NV class is split into classes System, DisplayManager and ProfileManager
    • methods NV::setScaling, NV::setEdid are refactored into DisplayManger::setScalingAll and DisplayManger::setEDIDAll
    • class Mode is renamed into DisplayMode
    • per-row and and per-column property names in class DisplayGrid now starts with either row or col prefix

4. OS-specific Implementation Details

Windows XP has limited support. Supported classes are:
  • System
  • Gpu
  • Board
  • Cooler
  • ThermalProbe
  • CoolerEvent
  • ThermalEvent

NVWMI Performance counter provider does not support Windows XP.

5. General Implementation Details

NVWMI implements several WMI providers inside \\.\root\cimv2\nv namespace:
  • instance provider
  • method provider
  • property provider
  • event provider
  • performance counters provider

All classes are statically defined in the MOF file, there are no dynamically defined classes (e.g. no class provider).

Static vs. dynamic instances.
In WMI, there are two separate types of object instances - singletons and dynamic instances. If the MOF class is declared as a singleton, it has just one instance. The path to such an instance is always known to the WBEM engine. Therefore the exact path to the instance is not required to address the instance. All other classes have dynamic instances. This means that the user must specify either a precise path or WQL operator which addressess one or more instances.

classes System, DisplayManager and ProfileManager are declared as MOF singletons, all other classes have dynamic instancing. Thus addressing instances of any non-singleton class, requires either where WQL clause or instance path.

GPU handles
GPU handles are not guaranteed to persist across driver upgrades or hardware changes. Enabling or disabling hardware, installing new NVIDIA hardware, upgrading driver or changing SLI configuration might change value of any GPU handle.

Object reference
"Object reference" is a UTF-16 string which contains the path to the WMI object. References could be used to build WQL queries. References (i.e. object paths) could be used to address instances.

There is a potential for signed/unsigned mismatch, as the WMI COM interface IWbemClassObject requires that even uint32 MOF type is set as a variant of VI_I4 type. Conversely, when retrieving properties of WMI objects via IWbemClassObject::Get, supply CIMTYPE* pvtType to retrieve the correct type. Do not rely on VARIANT* pVal.

For more information about IWbemClassObject::Get, see MSDN article about IWbemClassObject::Get

Example of the object reference (relative to NV namespace):

Mode.id=452288000
references instance of the Mode class with id=452288000. Mode instance with this id corresponds to the 1600x1200x32 Hz display mode (for versions 2.2, 2.3). Note that for classes with multiple keys, the reference string must contain all of them. Here is an example of Gpu instance reference:
Gpu.id=3137339648,uname="Quadro 5000"
When specifying references at command line, be sure to use quotation marks as appropriate (remember that reference is a string) - example of setting display mode on remote system wks-1
wmic /node:"wks-1" /namespace:nv path displaygrid where id=0 call setModeRef "Mode.id=452288000"

6. WMI General Information

Please refer to the MSDN documentation on WMI providers for information about general functionality and use.

Links to relevant MSDN pages:

WMI Reference
Creating WMI clients

NVIDIA
Copyright (c) 2010-2012 NVIDIA Corporation. All rights reserved.


April
2012
  • Main Page
  • Related Pages
  • Classes

Legal Notice

Copyright (c) 2010-2012 NVIDIA Corporation. All rights reserved.

Notice
This software may not, in whole or in part, be copied through any means, mechanical, electromechanical, or otherwise, without the express permission of NVIDIA Corporation.

Information furnished is believed to be accurate and reliable. However, NVIDIA assumes no responsibility for the consequences of use of such information nor for any infringement of patents or other rights of third parties, which may result from its use. No License is granted by implication or otherwise under any patent or patent rights of NVIDIA Corporation. Specifications mentioned in the software are subject to change without notice.

NVIDIA Corporation products are not authorized for use as critical components in life support devices or systems without express written approval of NVIDIA Corporation.

Trademarks
NVIDIA and the NVIDIA logo are registered trademarks or trademarks of NVIDIA Corporation in the United States and/or other countries.

Microsoft, Windows, and the Windows logo are registered trademarks of Microsoft Corporation.

Other company and product names may be trademarks or registered trademarks of the respective companies with which they are associated.


April
  • Classes

Cooler and Thermal Events

Cooler Events and Diagnostics

What is Fan Percent Speed? It is the current speed of the fan, normalized between 0-100%, where 0% means the fan is not spinning at all and 100% means the fan is spinning at its maximum possible speed.

The fan speed varies dynamically, without user or system intervention, within the minimum and maximum allowed speeds depending on GPU temperature. Normally, the fan is not required to spin at 100% as the fan is designed to maintain operational temperature at a lower speed. Therefore, the maximum allowed fan percent speed may be less than 100%. This also increases fan life and is acoustically better.

The fan is never supposed to be at 0% for desktop systems unless the system is shut down, in Standby mode (S3), or in Hibernate mode (S4).

Every NVIDIA GPU board has its own maximum and minimum fan speed percentage values.

Users can manually override the fan percent speed via NVAPI, however, GPU functionality may be affected if the user changes the speed beyond the minimum or maximum allowed speeds.

What is Fan Mechanical Speed/RPM? The fan mechanical speed is the physical measurement of the number of fan rotations per minute (RPM). The board has a dedicated tachometer which measures this value. The relationship between fan speed percent and mechanical speed is roughly linear, but the actual mapping is dependent on the physical cooler such that different boards and coolers will produce different fan mechanical speeds for the same percent speeds.

How is Expected Fan Mechanical Speed calculated? The expected fan mechanical speed is the desired number of fan revolutions per minute (RPM) with respect to the current fan speed percent. It’s calculated by linearly interpolating the current fan speed with minimum & maximum values of percent speed and RPM.

Below is the formula used for calculating expected RPM:

ERPM = MinRPM + ((CurPctSpeed - MinPctSpeed) * ((MaxRPM - MinRPM) / (MaxPctSpeed - MinPctSPeed)))

Where:
ERPM –> Expected fan mechanical speed (RPM)
CurPctSpeed -> Current fan percent speed
MinPctSpeed –> Minimum fan percent speed
MaxPctSpeed –> Maximum fan percent speed
MinRPM –> Minimum RPMs with respect to Minimum fan percent speed
MaxRPM –> Maximum RPMs with respect to Maximum fan percent speed

What is Allowed Error Margin? It is the percent margin indicating the variation between electrical inputs and corresponding fan mechanical speed. Ideally mechanical speed should change linearly with electrical inputs, but based on statistical analysis, it’s slightly curved and is found to be in the range of 15%.

Description of Fan events & diagnostics:
1) Normal – Fan is spinning as expected and designed, within the allowed error margin.
Diagnostics – Fan is in working condition, no action is required.

2) Warning – Fan is spinning either faster or slower than expected beyond the allowed error margin but less than 100% difference.
Diagnostics – Check for any obstruction or dust and clean the fan. If fan continues to be in warning state, then fan mechanical components may be failing out.

3) Critical – Fan is spinning either faster or slower than expected with greater than 100% difference from expected value. The fan may be stopped.
Diagnostics – Check for any obstruction or dust and clean the fan. If fan continues to be in the Critical state, mechanical components have likely failed or will fail soon and operator needs to seek replacement.

Thermal Events and Diagnostics

What is Thermal Slowdown? Thermal slowdown is a mechanism which automatically reduces clocks when temperature reaches a critical point/threshold – usually around 100C. This mechanism helps prevent thermal runaway and permanent damage to the chip/board.

Description of Thermal events & diagnostics:
1) Normal – Temperature is within normal operating ranges – i.e. more than 10C below the slowdown threshold temperature.
Diagnostics – GPU is functioning normally

2) Warning – Temperature is within 10C of thermal slowdown threshold temperature.
Diagnostics – Check if the fan is spinning properly (verify the fan event in addition) and that automatic variable fan control is enabled. Ensure that the system has proper ventilation and system fan is running properly. In addition, any running application should be closed to see if the temperature is returning to normal level after some time. If the warning is cleared by doing this (and normal event is generated), report this behavior to administrator.

3) Critical – Temperature has reached thermal slowdown threshold temperature.
Diagnostics – Check if the temperature is reduced after closing the application(s) running on the system, if the temperature is reduced (and normal event is generated) then report this matter to administrator and stop using that application until it’s fixed. If the problem persists even without any application running on that system then immediately stop using that GPU and contact administrator for further help. Note that GPU will engage in built-in slow down mechanism, which may reduce the temperature leading to generation of warning or normal event If this happens, please report this behavior to administrator. But if the temperature keeps on rising, then build-in shutdown mechanism will trigger to prevent damage.


April

Using NVWMI

General Information about NVWMI Clients

NVWMI implements WMI provider interfaces and general guidelines for WMI provider usage applies. See MSDN article Using WMI. Recommendations for selecting a language for NVWMI client implementation:
  • WinScript
    Both VisualBasic Script and JavaScript could be used. See MSDN article Scripting API for WMI for details. Implementation complexity is low for simple scripts, but quickly rise with development.
    Not recommended for any complex clients.
  • PowerShell
    Recommended way to create NVWMI clients of low to moderate complexity. See MS TechNet articles Get-WmiObject and Invoke-WmiMethod. There is a useful utility for exploring WMI objects - WMI Explorer.
    Moderate implementation complexity.
  • WMIC - WMI Console
    WMIC is a standard utility for MS Windows since Windows XP. It has command-line interface and could operate in batch or interactive mode. See Using NVWMI with the WMIC tool for details. Should not be used in applications.
    Recommended as a tool for quick testing only - see also WMIC Known limitations.
  • .NET/C#/Managed C++
    Recommended for complex NVWMI client applications. See MSDN article WMI .NET OverviewHigh implementation complexity.
  • DCOM/C++
    Recommended for complex NVWMI client applications. See MSDN article COM API for WMI Highest implementation complexity.

Diagnostic and troubleshooting

Controlling NVWMI Service

-In Services GUI application
  • browse running services
  • locate and select "NVIDIA WMI Provider"
  • click "Stop Service" button on the toolbar or "Stop" link in the left pane
You might pause and start the NVWMI service in a similar way.
-In command shell (CMD prompt)
To stop NVWMI service:
sc stop nvwmi
To start NVWMI service:
sc start nvwmi
To query whether NVWMI service is running:
sc query nvwmi
Logging off and logging on in interactive local session (not RDP), OS restart will restart NVWMI as well.

Using NVWMI logging to diagnose issues

See Examples of Useful Logging configurations . Enabling errors and warnings in the OS event log is recommended to diagnose and triage hardware or driver issues against NVWMI.


April

NVIDIA Performance Counters

Introduction

NVWMI provides performance counters with information about the state of NVIDIA hardware in real-time. Available performance counters are described in the manifest file System%\nvPerfProvider.man.

Performance counters are accessible using standard OS tools such as Microsoft Performance Monitor or programmatically. Microsoft supplies the Performance Monitor tool in all supported versions of the OS.

Read About Performance Counters for general outline.

For more technical details see Overview of Windows Performance Monitor.

Available NVIDIA Counters

  • GPU Free Physical Frame Buffer (in MB)
  • GPU Physical Frame Buffer (in MB)
  • GPU Virtual Frame Buffer (in MB)
  • GPU Memory Clock (in MHz)
  • GPU Clock (in MHz)
  • GPU % Fanspeed
  • GPU Temperature (in C)

Working with Windows Performance Monitor

1. Monitoring the counter graph

  • Run perfmon.exe
  • Browse to Performance->Monitoring Tools->Performance Monitor in the navigation bar
  • Select item Add counters from context menu (right-click in graph area)
  • Select target system (local or remote)
  • Browse the list to find NVIDIA Counters
  • Expand NVIDIA Counters item
  • Select any counter from the list, multiple selections supported
  • Select the instance of that counter from the instance list below
  • Add the counter instance and press OK
  • Choose appropriate graph scale and sampling rate

2. Creating a custom counter data set

  • Run perfmon.exe
  • Select Data Collector Sets
  • Select User Defined node and bring up its context menu (by right click)
  • Select New, Data collector Set
  • Select Create data logs, Performance counter and click on Next
  • Select Add
  • Select desired counters (for example, Processor Time), Add and click on OK
  • Select Next
  • Browse to a folder, select Next
  • Click on Change button to specify desired credentials under Run as
  • Select Save, Close and click on Finish
  • The user data collector is created
  • Bring up context menu (right click on the created data set) and select Start
  • Properties could be changed at any time via context menu (right click)
  • To stop collecting data, select Stop in the context menu

Diagnostics and troubleshooting

When NVWMI system service is not properly installed, NVIDIA performance counters are also not available. See Controlling NVWMI Service for service troubleshooting.
The manifest file nvPerfProvider.man must be properly registered and enabled.

Manual installation

  • C:\>lodctr /M:nvPerfProvider.man - Registers counters by writing GUID to [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib\_V2Providers]
  • C:\>lodctr /E:nvWmi64.exe - Enables performance counters. For 32-bit OS substitute nvWmi.exe
  • sc start nvwmi - Starts the service, counters should be available.
    Attention:
    NVWMI service is presumed to be stopped

Manual uninstallation

  • C:\>unlodctr /M:nvPerfProvider.man - Removes counters GUID from [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Perflib\_V2Providers]
  • C:\>lodctr /D:nvWmi64.exe - Disables performance counters. For 32-bit OS substitute nvWmi.exe
  • sc stop nvwmi - Stops the service, counters will not be provided anymore.
    Attention:
    NVWMI service is presumed to be running


April

Logging and tracing NVWMI activity

NVWMi equipped with robust logging and tracing capabilities. Clients can select logging types and control logging levels. Supported logging types:
  • MS Windows Event log
  • Debugger message stream
  • File log

Note that for logging types or logging filter changes to be in effect, NVWMI service restart is required. See Controlling NVWMI Service stopping and starting NVWMI.

Logging Types

Logging types are controlled by the registry value HKLM\SOFTWARE\NVIDIA Corporation\NVWMI\LogTypes.
It is a bitmask, several values might be combined to enable several logging types at once. Supported types are:
  • Debug stream.
    Any application, capable of capturing Win32 OutputDebugString. For example - DebugView, WinDbg, Visual Studio debugger.
    LogTypes=1
  • File log.
    %ALLUSERSPROFILE%\nvwmi.log will be produced with records in format <date> <timestamp> : <message text>
    LogTypes=2
  • MS OS event log.
    Could be examined by Event Viewer - standard utility of MS Windows. Or any other application which is capable of attaching to the MS Windows event log. Event Viewer requires manual refresh (hotkey F5) to monitor events. NVWMI events are logged in Application log. Event source is NVWMI.
    LogTypes=4
    Setting LogType to 0 will disable logging completely (silent mode).

Configuring Logging Filter

Logging filter is controlled by the registry value HKLM\SOFTWARE\NVIDIA Corporation\NVWMI\LogFilter.
It is a bitmask, several values might be combined to filter out messages of several levels at once.
LogFilter=1 - traces
LogFilter=0x10 - errors
LogFilter=0x100 - warnings
LogFilter=0x1000 - function entries
LogFilter=0x10000 - informational messages
LogFilter=0x11111 will disable message filtering (all messages will be logged),
LogFilter=0 will filter out all messages (silent).

Examples of Useful Logging configurations

This registry script will enable logging to OS event log. Only error messages will be logged, all other messages will be discarded:
[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\NVWMI]
"LogFilter"=dword:00000010
"LogTypes"=dword:00000004
Registry script to enable logging to the debug stream and OS event log. All messages will be logged (maximum verbosity):
[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\NVWMI]
"LogFilter"=dword:00111111
"LogTypes"=dword:00000005
Disable all logging:
[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\NVWMI]
"LogTypes"=dword:00000000


April

Using NVWMI with the WMIC tool

Examples of WMIC command-lines

You could set default namespace to root\cimv2\nv (otherwise path <object> won't work) or specify /namespace:nv at the command line:
 wmic:root\cli>/namespace:nv
List all NV singleton properties:
wmic:root\cli>path nv get *
Default verb is get, it could be skipped, so command
wmic:root\cli>path nv
will produces same output:
currentProfile3D                  currentProfileDesktop  defaultProfile3D                  defaultProfileDesktop
3D App - Default Global Settings  Default                3D App - Default Global Settings  Default
   {}                     3  Version.orderedValue=33554432  Version    Version  2  33554432  2.0.0    33554432
   {}                     3  Version.orderedValue=2800000   Version    Version  2  2800000   280.00   28000
   {}                     3  Version.orderedValue=0         Version    Version  2  0         unknown  0
   {}                     3  Version.orderedValue=0         Version    Version  2  0         unknown  0
   {}                     3  Version.orderedValue=16777216  Version    Version  2  16777216  0x1.00   16777216
   {}                     3  Version.orderedValue=50593792  Version    Version  2  50593792  0x3.04   50593792
   {}                     3  Version.orderedValue=33554432  Version    Version  2  33554432  2.0.0    33554432

List all GPUs (see Gpu) in a system - in this example there are 2 Quadro 4000 GPUs on 2 separate boards and 2 Quadro NVS 450 GPUs on the same board:

 wmic:root\cli>path gpu get *

Produces this output:

boardName       coreCount  frameBufferWidth  gpuClockFrequency  handle       id                             luid         memClockFrequency  name            ordinal  physicalFrameBufferSize  total  type
Quadro 4000     256        256               101000             -1157627648  -1157627648                    -1157627648  135000             Quadro 4000     1        2097152                  2      2
    {}                 3            Version.orderedValue=33554434  Version                         Version         2        33554434                 2.0.2  33554434
Quadro NVS 450  8          64                338000             -1157626624  -1157626624                    -1157626624  100000             Quadro NVS 450  1        262144                   2      4
    {}                 3            Version.orderedValue=33554434  Version                         Version         2        33554434                 2.0.2  33554434
Quadro NVS 450  8          64                1200000            -1157626368  -1157626368                    -1157626368  700000             Quadro NVS 450  2        262144                   2      4
    {}                 3            Version.orderedValue=33554434  Version                         Version         2        33554434                 2.0.2  33554434
Quadro 4000     256        256               810000             -1157626112  -1157626112                    -1157626112  1404000            Quadro 4000     2        2097152                  2      2
    {}                 3            Version.orderedValue=33554434  Version                         Version         2        33554434                 2.0.2  33554434

Invoking WMI methods in WMIC

Be aware of a difference between singleton class and classes with dynamic instances as it affects the way WMI methods are called in general. See static vs. dynamic instances in the Introduction.
Calling methods of NV class (singleton) without any parameters:
wmic /namespace:nv path nv call info
wmic /namespace:nv path nv call restoreDefaults
Calling methods of NV class (singleton) with input parameter (in this example - global profile name is "Avid Deko - compatible"):
wmic /namespace:nv path nv call setCurrentProfile "Avid Deko - compatible"
Calling methods of any other class (non-singleton) - general format:
wmic /namespace:nv path <class name> where <instance selection clause> call <method name> <parameters>
Calling methods of any other class (non-singleton) - example of calling Gpu::Info() :
wmic /namespace:nv path Gpu where ordinal=1 call info
Getting some properties (since version 2.3)
wmic /namespace:nv path <class name> where <instance selection clause> get <property list>
For example, listing just uname and id property of all Gpu instances (note that where clause is skipped as it is query for all instances)
wmic /namespace:nv path Gpu get uname,id

Note that where clause is a system-dependent. Example demonstrates calling Gpu::info on a system with Quadro 5000 GPU:

wmic /namespace:nv path gpu where name="Quadro 5000" call info

Calling a method of MOF class with dynamic instances and input parameters is performed in similar way. Example demonstrates changing scaling mode to produce image centered on a screen without any scaling (scaling mode value=3) for the instance of the DisplayTarget class with unique name "DisplayTarget 0:0"

wmic /namespace:nv path DisplayTarget where uname="DisplayTarget 0:0" call setScaling 3

The following is an example of calling a method with multiple input parameters using 'named parameters' convention. Note that displayIds is an array of negative numbers

wmic /namespace:nv path nv call createDisplayGridById rows=2 cols=1 displayIds=(-2147086206,-2147086207)

Any property could be used to select instance (or multiple instances at once). However, due to WMIC limitations it is not possible to specify NamedObject::id with negative values. For example, GPU ids have highest bit set and therefore WMIC treats them as negative numbers. See WMIC Known limitations.

WMIC Useful options

  • execute WMIC command on remote system:
    /node:<system name>
    Note that if the system name contains a hyphen (-) then it must be escaped or the system name enclosed in single quotes ('):
    wmic /node:'wks-1' /namespace:nv path gpu
    will get all instances of the Gpu class on the system with Windows name wks-1
  • trace execution of the WMI command
    /trace:on
  • record WMIC commands including their output with timestamps to an XML file
    /record:<file path>
  • select format of the WMI command output
    /format:<format specifier>
    Specifies a key word or XSL file name to format the data.
    Command
    wmic process list /format /?
    will list all available formats.
  • list all properties with their names when using GET * verb
    wmic /namespace:nv path <classname> get * \value
See also WMIC documentation on MSDN

WMIC Known limitations

  • WMIC doesn't allow specifying negative numbers. A minus character ('-') is treated as a switch. This prevents some legitimate commands from producing correct output. For example, this command will fail:
    wmic /namespace:nv path gpu where handle=-1157627648
    A slash ('/') and backslash ('\') are also special characters and should be either escaped or a string with these characters should be quoted literally (enclosed in apostrophes '). For example, be sure to quote computer name in node: parameter if it contains any special characters.
  • WMIC is case-insensitive for class names and properties. However, method names are case-sensitive.
  • WMIC doesn't display properties which contain array of object references (for example, Board::gpus).


April

Using NVWMI with the PowerShell

Examples of PowerShell command-lines

PowerShell has cmdlet Get-WmiObject to directly access and manipulate WMI objects. See MSDN article Using the Get-WMiObject Cmdlet. GWMI and gwmi are recognized as built-in aliases for Get-WmiObject.

Other helpful cmdlets to examine WMI objects are Get-member, Select-object, Sort-object and Where-object. For more tips of WMI scripting in PowerShell see Microsoft's TechNet article Scripting for WMI

Listing Gpu::id property for all Gpu instances (note that namespace is case-insensitive):

Get-WmiObject -namespace "root\cimv2\nv" -query "select id from Gpu"

WMI methods invocation:

$instance=gwmi -namespace "root\cimv2\nv" -class nv
$result=$instance.InvokeMethod("info",$null,$null)

Alternate way of accessing WMI objects - retrieving an instance of NV singleton, calling method NV::info() and storing result:

$instance = [wmiclass]"\\.\root\cimv2\nv:nv"
$rc=$mc.invokeMethod("info",$null)

Shorter version:

([wmiclass]"\\.\root\cimv2\nv:nv").invokeMethod("info",$null)
Note that it works only for singleton NV.
Running WQL query which selects certain property from WMI object(s).
$qr = Get-WmiObject -namespace "root\cimv2\nv" -Query "select uname from Gpu where ordinal=1"
foreach ($t in $qr) {$t.uname}
In case of more than one GPUs $qr will contain more than one element.

Selecting all instances and then iterating:

$gpus = Get-WmiObject -namespace "root\cimv2\nv" -class gpu
foreach($o in $gpus) # obtain an instance
{
    # print some properties
    "id="+$o.id+" uname="+$o.uname+" GPU clock="+$o.gpuClockFrequency
    # invoke info method
    $o.invokeMethod("info",$null)
}


April
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Board Class Reference

Inheritance diagram for Board:

NamedObject

List of all members.

Public Member Functions

string | info ()
Formats basic information about Board instance into a human-readable string.

Public Attributes

Gpu ref | gpus []
ThermalProbe ref | thermalProbes []
Array of thermal probes of this board.
Cooler ref | coolers []
Array of references to coolers of this board.
Version ver
uint32 | id
Unique id of named object, used as a key.
string | name
Name of an object.
string | uname
Unique name of an object.
sint32 | ordinal
Ordinal number of named object among objects with same names.
sint32 | count
Total number of named objects with same name.

Member Function Documentation

string info ( )

Formats basic information about Board instance into a human-readable string.

Member Data Documentation

Cooler ref coolers[]

Array of references to coolers of this board.

sint32 count [inherited]

Total number of named objects with same name.

Gpu ref gpus[]

Array of references to GPUs installed on this board

uint32 id [inherited]

Unique id of named object, used as a key.

string name [inherited]

Name of an object.

sint32 ordinal [inherited]

Ordinal number of named object among objects with same names.

ThermalProbe ref thermalProbes[]

Array of thermal probes of this board.

string uname [inherited]

Unique name of an object.

Version ver [inherited]

Version of named object

The documentation for this class was generated from the following file:
  • nvwmi.mof


April
  • Class Hierarchy
  • Class Members

Cooler Class Reference

List of all members.

Public Member Functions

string | info ()
Formats basic information about the Cooler object in a system into a human-readable string.

Public Attributes

Version ver
uint32 | handle
Unique identification of the NVIDIA GPU.
uint32 | percentCoolerRate
Current percentage speed of a cooler fan (or liquid flow rate %).
uint32 | fanSpeed
Current tachometer reading of fan speed in rpm.
uint32 | coolerLevel
Current Level (Normal, Warning or Critical) of the cooler.

Member Function Documentation

string info ( )

Formats basic information about the Cooler object in a system into a human-readable string.

Member Data Documentation

uint32 coolerLevel

Current Level (Normal, Warning or Critical) of the cooler.

uint32 fanSpeed

Current tachometer reading of fan speed in rpm.

uint32 handle

Unique identification of the NVIDIA GPU.

uint32 percentCoolerRate

Current percentage speed of a cooler fan (or liquid flow rate %).

Version ver

Cooler class version

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

CoolerEvent Class Reference

List of all members.

Public Attributes

uint32 | handleGpu
uint32 | coolerIndex
Cooler index in array of coolers on a given GPU.
uint32 | coolerLevel
Cooler level to identify the cooler zone.

Member Data Documentation

uint32 coolerIndex

Cooler index in array of coolers on a given GPU.

uint32 coolerLevel

Cooler level to identify the cooler zone.

uint32 handleGpu

Unique identification of the NVIDIA GPU

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

Display Class Reference

Inheritance diagram for Display:

NamedObject

List of all members.

Public Member Functions

boolean | restoreNativeDisplayMode ()
Restore the display mode to native.
boolean | setEDID ([in]string filePath)
Override display EDID with custom EDID. Displays must be physically connected while forcing EDID.
boolean | setScaling ([in, ValueMap{"0","1","2","3","5","6","7"}, Values{"Default","Closest","Native","ScanoutToNative","AspectScanoutToNative","AspectScanoutToClosest","ScanoutToClosest"}] uint32 scaling)
Change scaling mode of this display.
string | info ()
Formats basic information about this display into a human-readable string.

Public Attributes

Version verFirmware
string | make
Manufacturer of this display.
string | model
Model of this display.
DisplayMode displayModeNative
Native display mode.
uint32 | scaling
Display scaling mode - Invalid, Display, Center, FixedAspect, Fill.
uint8 | EDID []
Raw EDID of this display.
uint32 | EDIDSize
Size of the EDID in bytes.
uint32 | gpuConnectorType
Physical Connector, connected on the GPU.
boolean | isActive
True if display is active.
Mode ref | displayModes []
Array of references to the Display modes.
Version ver
uint32 | id
Unique id of named object, used as a key.
string | name
Name of an object.
string | uname
Unique name of an object.
sint32 | ordinal
Ordinal number of named object among objects with same names.
sint32 | count
Total number of named objects with same name.

Member Function Documentation

string info ( )

Formats basic information about this display into a human-readable string.

boolean restoreNativeDisplayMode ( )

Restore the display mode to native.

boolean setEDID ( [in] string filePath )

Override display EDID with custom EDID. Displays must be physically connected while forcing EDID.

Parameters:
filePath Custom EDID file path seperated with '\'. This must be empty for removing the forced EDID.

boolean setScaling ( [in, ValueMap{"0","1","2","3","5","6","7"}, Values{"Default","Closest","Native","ScanoutToNative","AspectScanoutToNative","AspectScanoutToClosest","ScanoutToClosest"}] uint32 scaling )

Change scaling mode of this display.

Parameters:
scaling scaling mode to be set

Member Data Documentation

sint32 count [inherited]

Total number of named objects with same name.

DisplayMode displayModeNative

Native display mode.

Mode ref displayModes[]

Array of references to the Display modes.

uint8 EDID[]

Raw EDID of this display.

uint32 EDIDSize

Size of the EDID in bytes.

uint32 gpuConnectorType

Physical Connector, connected on the GPU.

uint32 id [inherited]

Unique id of named object, used as a key.

boolean isActive

True if display is active.

string make

Manufacturer of this display.

string model

Model of this display.

string name [inherited]

Name of an object.

sint32 ordinal [inherited]

Ordinal number of named object among objects with same names.

uint32 scaling

Display scaling mode - Invalid, Display, Center, FixedAspect, Fill.

string uname [inherited]

Unique name of an object.

Version ver [inherited]

Version of named object

Version verFirmware

Firmware version of this display

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

DisplayGrid Class Reference

Inheritance diagram for DisplayGrid:

NamedObject

List of all members.

Public Member Functions

boolean | setOverlapRow ([in]sint32 index,[in]sint32 overlap)
Change per-row overlap of the display grid item with given index.
boolean | setOverlapCol ([in]sint32 index,[in]sint32 overlap)
Change columnar overlap of the display grid item with given index.
boolean | setOverlaps ([in]sint32 index,[in]sint32 overlapRow,[in]sint32 overlapCol)
Change overlap of the display grid item with given index.
boolean | setDisplayMode ([in]uint32 width,[in]uint32 height,[in]real32 refreshRate,[in]uint32 depth)
Change mode of this display grid.
boolean | setDisplayModeById ([in]uint32 id)
Change mode of this display source.
boolean | setDisplayModeByRef ([in]DisplayMode ref gridMode)
Change mode of this display grid.
string | info ()
Formats basic information about this Display grid into a human-readable string.

Public Attributes

uint32 | rows
uint32 | cols
Number of columns in the grid.
sint32 | overlapRows []
Distance between displays per row. Positive number indicates overlap, negative - gap (in pixels).
sint32 | overlapCols []
Distance between displays per column. Positive number indicates overlap, negative - gap (in pixels).
OverlapLimits overlapLimits
Overlap limits (in pixels) for this display grid.
DisplayMode displayModeVirtual
Effective mode of this display grid (including overlaps).
DisplayMode displayModePhysical
Current mode of this display grid (per-display).
sint32 | positionCol
Column-wise (horizontal) position of the display grid (in pixels).
sint32 | positionRow
Row-wise (vertical) position of the display grid (in pixels).
DisplayMode ref | displayModes []
Array of references to modes available on this display grid.
Display ref | displays []
Array of references to displays bound into this display grid.
Gpu ref | gpus []
Array of references to GPUs, driving displays on this display grid.
Version ver
uint32 | id
Unique id of named object, used as a key.
string | name
Name of an object.
string | uname
Unique name of an object.
sint32 | ordinal
Ordinal number of named object among objects with same names.
sint32 | count
Total number of named objects with same name.

Member Function Documentation

string info ( )

Formats basic information about this Display grid into a human-readable string.

boolean setDisplayMode | ( | [in] uint32 | width,
 |  | [in] uint32 | height,
 |  | [in] real32 | refreshRate,
 |  | [in] uint32 | depth
 | ) |  |

Change mode of this display grid.

Parameters:
width | Width of the display grid (in pixels)
height | Height of the display grid (in pixels)
refreshRate | Refresh rate of the display grid (in Hz)
depth | Color depth of the display grid (in bits per pixel)

boolean setDisplayModeById ( [in] uint32 id )

Change mode of this display source.

Parameters:
id DisplayMode ID

boolean setDisplayModeByRef ( [in] DisplayMode ref gridMode )

Change mode of this display grid.

Parameters:
gridMode A reference to the mode to be applied

boolean setOverlapCol | ( | [in] sint32 | index,
 |  | [in] sint32 | overlap
 | ) |  |

Change columnar overlap of the display grid item with given index.

Parameters:
index | Index of the column. Value -1 could be used to change overlap for all columns at once
overlap | Overlap. Positive number indicates overlap, negative - gap (in pixels)

boolean setOverlapRow | ( | [in] sint32 | index,
 |  | [in] sint32 | overlap
 | ) |  |

Change per-row overlap of the display grid item with given index.

Parameters:
index | Index of the column. Value -1 could be used to change overlap for all rows at once
overlap | Overlap. Positive number indicates overlap, negative - gap (in pixels)

boolean setOverlaps | ( | [in] sint32 | index,
 |  | [in] sint32 | overlapRow,
 |  | [in] sint32 | overlapCol
 | ) |  |

Change overlap of the display grid item with given index.

Parameters:
index | Index of the item. Value -1 could be used to change overlap for all items at once
overlapRow | Overlap. Positive number indicates overlap, negative - gap (in pixels)
overlapCol | Overlap. Positive number indicates overlap, negative - gap (in pixels)

Member Data Documentation

uint32 cols

Number of columns in the grid.

sint32 count [inherited]

Total number of named objects with same name.

DisplayMode displayModePhysical

Current mode of this display grid (per-display).

DisplayMode ref displayModes[]

Array of references to modes available on this display grid.

DisplayMode displayModeVirtual

Effective mode of this display grid (including overlaps).

Display ref displays[]

Array of references to displays bound into this display grid.

Gpu ref gpus[]

Array of references to GPUs, driving displays on this display grid.

uint32 id [inherited]

Unique id of named object, used as a key.

string name [inherited]

Name of an object.

sint32 ordinal [inherited]

Ordinal number of named object among objects with same names.

sint32 overlapCols[]

Distance between displays per column. Positive number indicates overlap, negative - gap (in pixels).

OverlapLimits overlapLimits

Overlap limits (in pixels) for this display grid.

sint32 overlapRows[]

Distance between displays per row. Positive number indicates overlap, negative - gap (in pixels).

sint32 positionCol

Column-wise (horizontal) position of the display grid (in pixels).

sint32 positionRow

Row-wise (vertical) position of the display grid (in pixels).

uint32 rows

Number of rows in the grid

string uname [inherited]

Unique name of an object.

Version ver [inherited]

Version of named object

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

DisplayGridInfo Class Reference

List of all members.

Public Member Functions

string | info ()
Formats basic information about the display grid information into a human-readable string.

Public Attributes

Version verClass
uint32 | id
Unique id of a display grid information, used as a key.
uint32 | rows
Number of rows in the display grid.
uint32 | cols
Number of columns in the display grid.
uint32 | displayIds []
Array of display IDs.
string | unames
String of unique display names (Display.uname), separated by semicolon. Order corresponds to displayIds property.

Member Function Documentation

string info ( )

Formats basic information about the display grid information into a human-readable string.

Member Data Documentation

uint32 cols

Number of columns in the display grid.

uint32 displayIds[]

Array of display IDs.

uint32 id

Unique id of a display grid information, used as a key.

uint32 rows

Number of rows in the display grid.

string unames

String of unique display names (Display.uname), separated by semicolon. Order corresponds to displayIds property.

Version verClass

Version of a display grid information

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

DisplayManager Class Reference

List of all members.

Public Member Functions

boolean | setScalingAll ([in, ValueMap{"0","1","2","3","5","6","7"}, Values{"Default","Closest","Native","ScanoutToNative","AspectScanoutToNative","AspectScanoutToClosest","ScanoutToClosest"}] uint32 scaling)
Change scaling mode of all display targets in a system.
boolean | createDisplayGridById ([in]uint32 cols,[in]uint32 rows,[in]uint32 displayIds[])
Create a display grid by specifying display IDs.
boolean | createDisplayGridByName ([in]uint32 cols,[in]uint32 rows,[in]string displayNames)
Create a display grid by specifying unique display names.
boolean | createDisplayGridByRef ([in]uint32 cols,[in]uint32 rows,[in]string displayRefs)
Create a display grid by specifying references references to the Display class instances.
boolean | setEDIDAll ([in]string filePath,[in, ValueMap{"0","0x10","0x11","0x13","0x14","0x16","0x17","0x18","0x19","0x1A","0x20","0x21","0x30","0x31","0x32","0x38","0x39","0x40","0x41","0x46","0x47","0x48","0x61","0x63","0x64","0x65"}, Values{"Vga15pin","TvComposite","TvSvideo","TvHdtvComponent","TvScart","TvCompositeScartOnEiaj4120","TvHdtvEiaj4120","PcPodHdtvYPrPb","PcPodSvideo","PcPodComposite","Dvi_iTvSvideo","Dvi_iTvComposite","Dvi_i","Dvi_d","Adc","LfhDvi_i1","LfhDvi_i2","Spwg","Oem","DisplayPortExternal","DisplayportInternal","DisplayportMiniExt","Hdmi_a","Hdmi_cMini","LfhDisplayPort1","LfhDisplayPort2"}] uint32 connectorType)
Sets custom EDID across all display ports.
string | info ()
Formats basic information about DisplayManager objects in a system into a human-readable string.

Public Attributes

Version verClass

Member Function Documentation

boolean createDisplayGridById | ( | [in] uint32 | cols,
 |  | [in] uint32 | rows,
 |  | [in] uint32 | displayIds[]
 | ) |  |

Create a display grid by specifying display IDs.

Parameters:
cols | number of columns in a grid (must be non-zero)
rows | number of rows in a grid (must be non-zero)
displayIds | array of display IDs (Display.id). Order is important. C convention for array - grid element at column=i and row=j must be at index=j*cols+i

boolean createDisplayGridByName | ( | [in] uint32 | cols,
 |  | [in] uint32 | rows,
 |  | [in] string | displayNames
 | ) |  |

Create a display grid by specifying unique display names.

Parameters:
cols | number of columns in a grid (must be non-zero)
rows | number of rows in a grid (must be non-zero)
displayNames | string of unique display names (Display.uname), separated by semicolon. Order is important. C convention for array - grid element at column=i and row=j must be at index=j*cols+i

boolean createDisplayGridByRef | ( | [in] uint32 | cols,
 |  | [in] uint32 | rows,
 |  | [in] string | displayRefs
 | ) |  |

Create a display grid by specifying references references to the Display class instances.

Parameters:
cols | number of columns in a grid (must be non-zero)
rows | number of rows in a grid (must be non-zero)
displayRefs | string of references to Display instances, separated by semicolon. Order is important. C convention for array - grid element at column=i and row=j must be at index=j*cols+i

string info ( )

Formats basic information about DisplayManager objects in a system into a human-readable string.

boolean setEDIDAll | ( | [in] string | filePath,
 |  | [in, ValueMap{"0","0x10","0x11","0x13","0x14","0x16","0x17","0x18","0x19","0x1A","0x20","0x21","0x30","0x31","0x32","0x38","0x39","0x40","0x41","0x46","0x47","0x48","0x61","0x63","0x64","0x65"}, Values{"Vga15pin","TvComposite","TvSvideo","TvHdtvComponent","TvScart","TvCompositeScartOnEiaj4120","TvHdtvEiaj4120","PcPodHdtvYPrPb","PcPodSvideo","PcPodComposite","Dvi_iTvSvideo","Dvi_iTvComposite","Dvi_i","Dvi_d","Adc","LfhDvi_i1","LfhDvi_i2","Spwg","Oem","DisplayPortExternal","DisplayportInternal","DisplayportMiniExt","Hdmi_a","Hdmi_cMini","LfhDisplayPort1","LfhDisplayPort2"}] uint32 | connectorType
 | ) |  |

Sets custom EDID across all display ports.

Parameters:
filePath | Custom EDID file path seperated with '\'. This must be empty for removing the forced EDID.
connectorType | Physical connector, connected to a GPU

boolean setScalingAll ( [in, ValueMap{"0","1","2","3","5","6","7"}, Values{"Default","Closest","Native","ScanoutToNative","AspectScanoutToNative","AspectScanoutToClosest","ScanoutToClosest"}] uint32 scaling )

Change scaling mode of all display targets in a system.

Parameters:
scaling Scaling mode to be set

Member Data Documentation

Version verClass

Object version

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

DisplayMode Class Reference

List of all members.

Public Member Functions

string | info ()
Formats basic information about this display mode into a human-readable string.

Public Attributes

Version verClass
uint32 | id
Unique identification of the display mode.
sint32 | width
Display mode width.
sint32 | height
Display mode height.
real32 | refreshRate
Display mode refresh rate.
sint32 | colorDepth
Display mode color depth in bits per pixel (bpp).

Member Function Documentation

string info ( )

Formats basic information about this display mode into a human-readable string.

Member Data Documentation

sint32 colorDepth

Display mode color depth in bits per pixel (bpp).

sint32 height

Display mode height.

uint32 id

Unique identification of the display mode.

real32 refreshRate

Display mode refresh rate.

Version verClass

Object version

sint32 width

Display mode width.

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

DisplayProfile Class Reference

Inheritance diagram for DisplayProfile:

Profile

List of all members.

Public Member Functions

boolean | setValueById ([in] uint32 settingId,[in] uint32 value)
Set the value for a setting.
string | info ()
Formats basic information about a profile into a human-readable string.

Public Attributes

DisplayGridInfo grid
Version verClass
uint32 | id
Unique id of a profile, used as a key.
string | name
Name of a profile.
uint32 | type
Profile type.
boolean | isPredefined
If true, profile is predefined and cannot be removed.
boolean | isSupported
If true, profile is supported on this system.
Setting settings []
Array of settings for a profile.

Member Function Documentation

string info ( ) [inherited]

Formats basic information about a profile into a human-readable string.

boolean setValueById | ( | [in] uint32 | settingId,
 |  | [in] uint32 | value |
 | ) |  |  | [inherited]

Set the value for a setting.

Parameters:
settingId | Setting Id
value | Value that needs to be set

Member Data Documentation

DisplayGridInfo grid

information about a display grid

uint32 id [inherited]

Unique id of a profile, used as a key.

boolean isPredefined [inherited]

If true, profile is predefined and cannot be removed.

boolean isSupported [inherited]

If true, profile is supported on this system.

string name [inherited]

Name of a profile.

Setting settings[] [inherited]

Array of settings for a profile.

uint32 type [inherited]

Profile type.

Version verClass [inherited]

Version of a profile class

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

Gpu Class Reference

Inheritance diagram for Gpu:

NamedObject

List of all members.

Public Member Functions

string | info ()
Formats basic information about this GPU into a human-readable string.

Public Attributes

uint32 | handle
uint32 | productType
GPU type - UNKNOWN, GEFORCE, QUADRO, NVS, TESLA.
uint32 | memoryType
The type of memory associated with this GPU - SDRAM, DDR1, DDR2, GDDR2, GDDR3, GDDR4, DDR3, GDDR5.
uint32 | memorySizeVirtual
The virtual memory size in KB. (Physical RAM + System RAM).
uint32 | memorySizePhysical
The physical memory size in KB. (No system RAM).
uint32 | memorySizeAvailable
The current available physical memory size in kb. (No system RAM).
uint32 | memoryBusWidth
The width of the GPU's RAM memory bus.
uint32 | coreCount
The total number of Cores defined for a GPU.
uint32 | memoryClockCurrent
The current memory clock frequency in kHz.
uint32 | gpuCoreClockCurrent
The current GPU clock frequency in kHz.
ThermalProbe ref | thermalProbes []
Array of thermal probes of this GPU.
Cooler ref | coolers []
Array of references to coolers of this GPU.
string | productName
The name of the graphics card to which this GPU belongs.
Version verVBIOS
The video BIOS version associated with this GPU.
Version ver
uint32 | id
Unique id of named object, used as a key.
string | name
Name of an object.
string | uname
Unique name of an object.
sint32 | ordinal
Ordinal number of named object among objects with same names.
sint32 | count
Total number of named objects with same name.

Member Function Documentation

string info ( )

Formats basic information about this GPU into a human-readable string.

Member Data Documentation

Cooler ref coolers[]

Array of references to coolers of this GPU.

uint32 coreCount

The total number of Cores defined for a GPU.

sint32 count [inherited]

Total number of named objects with same name.

uint32 gpuCoreClockCurrent

The current GPU clock frequency in kHz.

uint32 handle

Unique identification of the NVIDIA GPU"

uint32 id [inherited]

Unique id of named object, used as a key.

uint32 memoryBusWidth

The width of the GPU's RAM memory bus.

uint32 memoryClockCurrent

The current memory clock frequency in kHz.

uint32 memorySizeAvailable

The current available physical memory size in kb. (No system RAM).

uint32 memorySizePhysical

The physical memory size in KB. (No system RAM).

uint32 memorySizeVirtual

The virtual memory size in KB. (Physical RAM + System RAM).

uint32 memoryType

The type of memory associated with this GPU - SDRAM, DDR1, DDR2, GDDR2, GDDR3, GDDR4, DDR3, GDDR5.

string name [inherited]

Name of an object.

sint32 ordinal [inherited]

Ordinal number of named object among objects with same names.

string productName

The name of the graphics card to which this GPU belongs.

uint32 productType

GPU type - UNKNOWN, GEFORCE, QUADRO, NVS, TESLA.

ThermalProbe ref thermalProbes[]

Array of thermal probes of this GPU.

string uname [inherited]

Unique name of an object.

Version ver [inherited]

Version of named object

Version verVBIOS

The video BIOS version associated with this GPU.

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

NamedObject Class Reference

Inheritance diagram for NamedObject:

Board Display DisplayGrid Gpu

List of all members.

Public Attributes

Version ver
uint32 | id
Unique id of named object, used as a key.
string | name
Name of an object.
string | uname
Unique name of an object.
sint32 | ordinal
Ordinal number of named object among objects with same names.
sint32 | count
Total number of named objects with same name.

Member Data Documentation

sint32 count

Total number of named objects with same name.

uint32 id

Unique id of named object, used as a key.

string name

Name of an object.

sint32 ordinal

Ordinal number of named object among objects with same names.

string uname

Unique name of an object.

Version ver

Version of named object

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

OverlapLimits Class Reference

List of all members.

Public Member Functions

string | info ()
Formats basic information about OverlapLimits instance into a human-readable string.

Public Attributes

Version verClass
uint32 | id
Unique identification of the overlap limits.
sint32 | minOverlapCol
The minimum column overlap for each display (in pixels).
sint32 | maxOverlapCol
The maximum column overlap for each display (in pixels).
sint32 | minOverlapRow
The minimum row overlap for each display (in pixels).
sint32 | maxOverlapRow
The maximum row overlap for each display (in pixels).
sint32 | minTotalCol
The minimum total column overlap for the entire grid (in pixels).
sint32 | maxTotalCol
The maximum total column overlap for the entire grid (in pixels).
sint32 | minTotalRow
The minimum total row overlap for the entire grid (in pixels).
sint32 | maxTotalRow
The maximum total row overlap for the entire grid (in pixels).

Member Function Documentation

string info ( )

Formats basic information about OverlapLimits instance into a human-readable string.

Member Data Documentation

uint32 id

Unique identification of the overlap limits.

sint32 maxOverlapCol

The maximum column overlap for each display (in pixels).

sint32 maxOverlapRow

The maximum row overlap for each display (in pixels).

sint32 maxTotalCol

The maximum total column overlap for the entire grid (in pixels).

sint32 maxTotalRow

The maximum total row overlap for the entire grid (in pixels).

sint32 minOverlapCol

The minimum column overlap for each display (in pixels).

sint32 minOverlapRow

The minimum row overlap for each display (in pixels).

sint32 minTotalCol

The minimum total column overlap for the entire grid (in pixels).

sint32 minTotalRow

The minimum total row overlap for the entire grid (in pixels).

Version verClass

Object version

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

Profile Class Reference

Inheritance diagram for Profile:

DisplayProfile

List of all members.

Public Member Functions

boolean | setValueById ([in] uint32 settingId,[in] uint32 value)
Set the value for a setting.
string | info ()
Formats basic information about a profile into a human-readable string.

Public Attributes

Version verClass
uint32 | id
Unique id of a profile, used as a key.
string | name
Name of a profile.
uint32 | type
Profile type.
boolean | isPredefined
If true, profile is predefined and cannot be removed.
boolean | isSupported
If true, profile is supported on this system.
Setting settings []
Array of settings for a profile.

Member Function Documentation

string info ( )

Formats basic information about a profile into a human-readable string.

boolean setValueById | ( | [in] uint32 | settingId,
 |  | [in] uint32 | value
 | ) |  |

Set the value for a setting.

Parameters:
settingId | Setting Id
value | Value that needs to be set

Member Data Documentation

uint32 id

Unique id of a profile, used as a key.

boolean isPredefined

If true, profile is predefined and cannot be removed.

boolean isSupported

If true, profile is supported on this system.

string name

Name of a profile.

Setting settings[]

Array of settings for a profile.

uint32 type

Profile type.

Version verClass

Version of a profile class

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

ProfileManager Class Reference

List of all members.

Public Member Functions

boolean | restoreDefaults3D ()
Restore all profiles to default.
boolean | setCurrentProfile3D ([in]string name)
Set current profile.
boolean | setVSync ([in, ValueMap{"0","1","2","3","4"}, Values{"Passive","Off","On","Adaptive","Adaptive half"}] uint32 vsyncMode)
Set mode of vertical synchronization in the current global profile.
boolean | loadDesktopProfile ([in]string name)
Load Desktop profile.
boolean | lockDesktopProfile ([in]string name,[in]uint32 lock)
Lock Desktop profile.
boolean | saveDisplayProfiles ([in]string prefix)
Save current display state in display profiles with given prefixes. One display profile per DisplayGrid. DisplayGrid might contain more than one physical display.
boolean | applyDisplayProfiles ([in]string prefix)
Apply saved state in display profiles with given prefixes. One display profile per DisplayGrid.
string | info ()
Formats basic information about Profile Manager into a human-readable string".

Public Attributes

Version verClass
string | currentProfile3D
Current Global 3D profile (D3D, OGL).
string | defaultProfile3D
Default Global 3D profile (D3D, OGL).

Member Function Documentation

boolean applyDisplayProfiles ( [in] string prefix )

Apply saved state in display profiles with given prefixes. One display profile per DisplayGrid.

Parameters:
prefix Common prefix - e.g. "my display" Ordinals will be added per every display profile (e.g. "my display 1 of 4", "my display 2 of 4" etc.)

string info ( )

Formats basic information about Profile Manager into a human-readable string".

boolean loadDesktopProfile ( [in] string name )

Load Desktop profile.

Parameters:
name Name of existing Desktop profile to be loaded

boolean lockDesktopProfile | ( | [in] string | name,
 |  | [in] uint32 | lock
 | ) |  |

Lock Desktop profile.

Parameters:
name | Name of existing Desktop profile to be locked
lock | To lock profile and unlock profile

boolean restoreDefaults3D ( )

Restore all profiles to default.

boolean saveDisplayProfiles ( [in] string prefix )

Save current display state in display profiles with given prefixes. One display profile per DisplayGrid. DisplayGrid might contain more than one physical display.

Parameters:
prefix Common prefix - e.g. "my display". Ordinals will be added per every display profile (e.g. "my display 1 of 4", "my display 2 of 4" etc.)

boolean setCurrentProfile3D ( [in] string name )

Set current profile.

Parameters:
name Name of existing profile to set as current

boolean setVSync ( [in, ValueMap{"0","1","2","3","4"}, Values{"Passive","Off","On","Adaptive","Adaptive half"}] uint32 vsyncMode )

Set mode of vertical synchronization in the current global profile.

Parameters:
vsyncMode V-Sync mode to be applied to the current global profile values might be Application-Controlled (same as Passive) = 0, Off = 1, On = 2, Adaptive = 3 and Adaptive(half refresh rate) = 4

Member Data Documentation

string currentProfile3D

Current Global 3D profile (D3D, OGL).

string defaultProfile3D

Default Global 3D profile (D3D, OGL).

Version verClass

Profile Manager class version

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

Setting Class Reference

List of all members.

Public Member Functions

string | info ()
Formats basic information about the Profile setting object into a human-readable string.

Public Attributes

Version verClass
uint32 | id
Unique id of a setting, used as a key.
uint32 | type
Type of value of the setting.
uint8 | value []
Value for the Setting.

Member Function Documentation

string info ( )

Formats basic information about the Profile setting object into a human-readable string.

Member Data Documentation

uint32 id

Unique id of a setting, used as a key.

uint32 type

Type of value of the setting.

uint8 value[]

Value for the Setting.

Version verClass

Version of a Setting class

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

System Class Reference

List of all members.

Public Member Functions

boolean | setnViewState ([in, ValueMap{"0","1"}, Values{"Disable","Enable"}] uint32 state)
Set nView Desktop Manager State.
string | info ()
Formats basic information about System objects into a human-readable string.

Public Attributes

Version verClass
Version verNVWMI
Version of the NVWMI driver.
Version verDisplayDriver
Version of the NV display driver.
Version verSDICaptureFirmware
Firmware version of the SDI Capture board.
Version verSDIOutputFirmware
Firmware version of the SDI output board.
Version verSDIOutputDriver
Driver version for the SDI output.
Version verSDICaptureDriver
Driver version for the SDI Capture driver.
Version verGSyncFirmware
Version of the G-Sync board firmware.
Version verVBIOS
The video BIOS version associated with the GPU's.
uint32 | nViewState
nView Desktop Manager State

Member Function Documentation

string info ( )

Formats basic information about System objects into a human-readable string.

boolean setnViewState ( [in, ValueMap{"0","1"}, Values{"Disable","Enable"}] uint32 state )

Set nView Desktop Manager State.

Parameters:
state nView State to be Set

Member Data Documentation

uint32 nViewState

nView Desktop Manager State

Version verClass

System root class version

Version verDisplayDriver

Version of the NV display driver.

Version verGSyncFirmware

Version of the G-Sync board firmware.

Version verNVWMI

Version of the NVWMI driver.

Version verSDICaptureDriver

Driver version for the SDI Capture driver.

Version verSDICaptureFirmware

Firmware version of the SDI Capture board.

Version verSDIOutputDriver

Driver version for the SDI output.

Version verSDIOutputFirmware

Firmware version of the SDI output board.

Version verVBIOS

The video BIOS version associated with the GPU's.

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

ThermalEvent Class Reference

List of all members.

Public Attributes

uint32 | handleGpu
uint32 | probeIndex
Thermal probe index in array of probes on a given GPU.
uint32 | thermalLevel
Thermal level to identify the temperature zone.

Member Data Documentation

uint32 handleGpu

Unique identification of the NVIDIA GPU

uint32 probeIndex

Thermal probe index in array of probes on a given GPU.

uint32 thermalLevel

Thermal level to identify the temperature zone.

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

ThermalProbe Class Reference

List of all members.

Public Member Functions

string | info ()
Formats basic information about the Thermal object in a system into a human-readable string.

Public Attributes

Version ver
uint32 | handle
Unique identification of the NVIDIA GPU.
sint32 | temperature
the current temperature value of the thermal sensor in degrees centigrade
uint32 | thermalLevel
current thermal level

Member Function Documentation

string info ( )

Formats basic information about the Thermal object in a system into a human-readable string.

Member Data Documentation

uint32 handle

Unique identification of the NVIDIA GPU.

sint32 temperature

the current temperature value of the thermal sensor in degrees centigrade

uint32 thermalLevel

current thermal level

Version ver

Thermal probe class version

The documentation for this class was generated from the following file:
  • nvwmi.mof


April

Version Class Reference

List of all members.

Public Attributes

uint32 | orderedValue
uint32 | value
Raw version value.
string | strValue
Human-readable string with version value.

Member Data Documentation

uint32 orderedValue

Ordered version value, guaranteed to grow monotonically

string strValue

Human-readable string with version value.

uint32 value

Raw version value.

The documentation for this class was generated from the following file:
  • nvwmi.mof


April
  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all class members with links to the classes they belong to:

- a -

  • applyDisplayProfiles() : ProfileManager

- c -

  • colorDepth : DisplayMode
  • cols : DisplayGrid , DisplayGridInfo
  • coolerIndex : CoolerEvent
  • coolerLevel : Cooler , CoolerEvent
  • coolers : Board , Gpu
  • coreCount : Gpu
  • count : NamedObject
  • createDisplayGridById() : DisplayManager
  • createDisplayGridByName() : DisplayManager
  • createDisplayGridByRef() : DisplayManager
  • currentProfile3D : ProfileManager

- d -

  • defaultProfile3D : ProfileManager
  • displayIds : DisplayGridInfo
  • displayModeNative : Display
  • displayModePhysical : DisplayGrid
  • displayModes : DisplayGrid , Display
  • displayModeVirtual : DisplayGrid
  • displays : DisplayGrid

- e -

  • EDID : Display
  • EDIDSize : Display

- f -

  • fanSpeed : Cooler

- g -

  • gpuConnectorType : Display
  • gpuCoreClockCurrent : Gpu
  • gpus : DisplayGrid , Board
  • grid : DisplayProfile

- h -

  • handle : Gpu , Cooler , ThermalProbe
  • handleGpu : ThermalEvent , CoolerEvent
  • height : DisplayMode

- i -

  • id : NamedObject , OverlapLimits , Setting , DisplayGridInfo , DisplayMode , Profile
  • info() : Setting , System , ThermalProbe , Cooler , DisplayMode , Display , ProfileManager , OverlapLimits , Profile , Board , DisplayManager , Gpu , DisplayGrid , DisplayGridInfo
  • isActive : Display
  • isPredefined : Profile
  • isSupported : Profile

- l -

  • loadDesktopProfile() : ProfileManager
  • lockDesktopProfile() : ProfileManager

- m -

  • make : Display
  • maxOverlapCol : OverlapLimits
  • maxOverlapRow : OverlapLimits
  • maxTotalCol : OverlapLimits
  • maxTotalRow : OverlapLimits
  • memoryBusWidth : Gpu
  • memoryClockCurrent : Gpu
  • memorySizeAvailable : Gpu
  • memorySizePhysical : Gpu
  • memorySizeVirtual : Gpu
  • memoryType : Gpu
  • minOverlapCol : OverlapLimits
  • minOverlapRow : OverlapLimits
  • minTotalCol : OverlapLimits
  • minTotalRow : OverlapLimits
  • model : Display

- n -

  • name : NamedObject , Profile
  • nViewState : System

- o -

  • orderedValue : Version
  • ordinal : NamedObject
  • overlapCols : DisplayGrid
  • overlapLimits : DisplayGrid
  • overlapRows : DisplayGrid

- p -

  • percentCoolerRate : Cooler
  • positionCol : DisplayGrid
  • positionRow : DisplayGrid
  • probeIndex : ThermalEvent
  • productName : Gpu
  • productType : Gpu

- r -

  • refreshRate : DisplayMode
  • restoreDefaults3D() : ProfileManager
  • restoreNativeDisplayMode() : Display
  • rows : DisplayGrid , DisplayGridInfo

- s -

  • saveDisplayProfiles() : ProfileManager
  • scaling : Display
  • setCurrentProfile3D() : ProfileManager
  • setDisplayMode() : DisplayGrid
  • setDisplayModeById() : DisplayGrid
  • setDisplayModeByRef() : DisplayGrid
  • setEDID() : Display
  • setEDIDAll() : DisplayManager
  • setnViewState() : System
  • setOverlapCol() : DisplayGrid
  • setOverlapRow() : DisplayGrid
  • setOverlaps() : DisplayGrid
  • setScaling() : Display
  • setScalingAll() : DisplayManager
  • settings : Profile
  • setValueById() : Profile
  • setVSync() : ProfileManager
  • strValue : Version

- t -

  • temperature : ThermalProbe
  • thermalLevel : ThermalProbe , ThermalEvent
  • thermalProbes : Board , Gpu
  • type : Setting , Profile

- u -

  • uname : NamedObject
  • unames : DisplayGridInfo

- v -

  • value : Version , Setting
  • ver : Cooler , ThermalProbe , NamedObject
  • verClass : OverlapLimits , DisplayMode , ProfileManager , Setting , System , DisplayGridInfo , Profile , DisplayManager
  • verDisplayDriver : System
  • verFirmware : Display
  • verGSyncFirmware : System
  • verNVWMI : System
  • verSDICaptureDriver : System
  • verSDICaptureFirmware : System
  • verSDIOutputDriver : System
  • verSDIOutputFirmware : System
  • verVBIOS : Gpu , System

- w -

  • width : DisplayMode


April

Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
Board
Cooler
CoolerEvent
Display
DisplayGrid
DisplayGridInfo
DisplayManager
DisplayMode
DisplayProfile
Gpu
NamedObject
OverlapLimits
Profile
ProfileManager
Setting
System
ThermalEvent
ThermalProbe
Version


April

Board Member List

This is the complete list of members for Board, including all inherited members.

coolers | Board
count | NamedObject
gpus | Board
id | NamedObject
info() | Board
name | NamedObject
ordinal | NamedObject
thermalProbes | Board
uname | NamedObject
ver | NamedObject


April

Cooler Member List

This is the complete list of members for Cooler, including all inherited members.

coolerLevel | Cooler
fanSpeed | Cooler
handle | Cooler
info() | Cooler
percentCoolerRate | Cooler
ver | Cooler


April

CoolerEvent Member List

This is the complete list of members for CoolerEvent, including all inherited members.

coolerIndex | CoolerEvent
coolerLevel | CoolerEvent
handleGpu | CoolerEvent


April

Display Member List

This is the complete list of members for Display, including all inherited members.

count | NamedObject
displayModeNative | Display
displayModes | Display
EDID | Display
EDIDSize | Display
gpuConnectorType | Display
id | NamedObject
info() | Display
isActive | Display
make | Display
model | Display
name | NamedObject
ordinal | NamedObject
restoreNativeDisplayMode() | Display
scaling | Display
setEDID([in]string filePath) | Display
setScaling([in, ValueMap{"0","1","2","3","5","6","7"}, Values{"Default","Closest","Native","ScanoutToNative","AspectScanoutToNative","AspectScanoutToClosest","ScanoutToClosest"}] uint32 scaling) | Display
uname | NamedObject
ver | NamedObject
verFirmware | Display


April

DisplayGrid Member List

This is the complete list of members for DisplayGrid, including all inherited members.

cols | DisplayGrid
count | NamedObject
displayModePhysical | DisplayGrid
displayModes | DisplayGrid
displayModeVirtual | DisplayGrid
displays | DisplayGrid
gpus | DisplayGrid
id | NamedObject
info() | DisplayGrid
name | NamedObject
ordinal | NamedObject
overlapCols | DisplayGrid
overlapLimits | DisplayGrid
overlapRows | DisplayGrid
positionCol | DisplayGrid
positionRow | DisplayGrid
rows | DisplayGrid
setDisplayMode([in]uint32 width,[in]uint32 height,[in]real32 refreshRate,[in]uint32 depth) | DisplayGrid
setDisplayModeById([in]uint32 id) | DisplayGrid
setDisplayModeByRef([in]DisplayMode ref gridMode) | DisplayGrid
setOverlapCol([in]sint32 index,[in]sint32 overlap) | DisplayGrid
setOverlapRow([in]sint32 index,[in]sint32 overlap) | DisplayGrid
setOverlaps([in]sint32 index,[in]sint32 overlapRow,[in]sint32 overlapCol) | DisplayGrid
uname | NamedObject
ver | NamedObject


April

DisplayGridInfo Member List

This is the complete list of members for DisplayGridInfo, including all inherited members.

cols | DisplayGridInfo
displayIds | DisplayGridInfo
id | DisplayGridInfo
info() | DisplayGridInfo
rows | DisplayGridInfo
unames | DisplayGridInfo
verClass | DisplayGridInfo


April

DisplayManager Member List

This is the complete list of members for DisplayManager, including all inherited members.

createDisplayGridById([in]uint32 cols,[in]uint32 rows,[in]uint32 displayIds[]) | DisplayManager
createDisplayGridByName([in]uint32 cols,[in]uint32 rows,[in]string displayNames) | DisplayManager
createDisplayGridByRef([in]uint32 cols,[in]uint32 rows,[in]string displayRefs) | DisplayManager
info() | DisplayManager
setEDIDAll([in]string filePath,[in, ValueMap{"0","0x10","0x11","0x13","0x14","0x16","0x17","0x18","0x19","0x1A","0x20","0x21","0x30","0x31","0x32","0x38","0x39","0x40","0x41","0x46","0x47","0x48","0x61","0x63","0x64","0x65"}, Values{"Vga15pin","TvComposite","TvSvideo","TvHdtvComponent","TvScart","TvCompositeScartOnEiaj4120","TvHdtvEiaj4120","PcPodHdtvYPrPb","PcPodSvideo","PcPodComposite","Dvi_iTvSvideo","Dvi_iTvComposite","Dvi_i","Dvi_d","Adc","LfhDvi_i1","LfhDvi_i2","Spwg","Oem","DisplayPortExternal","DisplayportInternal","DisplayportMiniExt","Hdmi_a","Hdmi_cMini","LfhDisplayPort1","LfhDisplayPort2"}] uint32 connectorType) | DisplayManager
setScalingAll([in, ValueMap{"0","1","2","3","5","6","7"}, Values{"Default","Closest","Native","ScanoutToNative","AspectScanoutToNative","AspectScanoutToClosest","ScanoutToClosest"}] uint32 scaling) | DisplayManager
verClass | DisplayManager


April

DisplayMode Member List

This is the complete list of members for DisplayMode, including all inherited members.

colorDepth | DisplayMode
height | DisplayMode
id | DisplayMode
info() | DisplayMode
refreshRate | DisplayMode
verClass | DisplayMode
width | DisplayMode


April

DisplayProfile Member List

This is the complete list of members for DisplayProfile, including all inherited members.

grid | DisplayProfile
id | Profile
info() | Profile
isPredefined | Profile
isSupported | Profile
name | Profile
settings | Profile
setValueById([in] uint32 settingId,[in] uint32 value) | Profile
type | Profile
verClass | Profile


April

Class Index

B | C | D | G | N | O | P | S | T | V

B
Display
G
P
T
Board DisplayGrid Gpu Profile ThermalEvent
C
DisplayGridInfo
N
ProfileManager ThermalProbe
Cooler DisplayManager NamedObject
S
V
CoolerEvent DisplayMode
O
Setting Version
D
DisplayProfile OverlapLimits System

B | C | D | G | N | O | P | S | T | V


April

Gpu Member List

This is the complete list of members for Gpu, including all inherited members.

coolers | Gpu
coreCount | Gpu
count | NamedObject
gpuCoreClockCurrent | Gpu
handle | Gpu
id | NamedObject
info() | Gpu
memoryBusWidth | Gpu
memoryClockCurrent | Gpu
memorySizeAvailable | Gpu
memorySizePhysical | Gpu
memorySizeVirtual | Gpu
memoryType | Gpu
name | NamedObject
ordinal | NamedObject
productName | Gpu
productType | Gpu
thermalProbes | Gpu
uname | NamedObject
ver | NamedObject
verVBIOS | Gpu


April

NamedObject Member List

This is the complete list of members for NamedObject, including all inherited members.

count | NamedObject
id | NamedObject
name | NamedObject
ordinal | NamedObject
uname | NamedObject
ver | NamedObject


April

OverlapLimits Member List

This is the complete list of members for OverlapLimits, including all inherited members.

id | OverlapLimits
info() | OverlapLimits
maxOverlapCol | OverlapLimits
maxOverlapRow | OverlapLimits
maxTotalCol | OverlapLimits
maxTotalRow | OverlapLimits
minOverlapCol | OverlapLimits
minOverlapRow | OverlapLimits
minTotalCol | OverlapLimits
minTotalRow | OverlapLimits
verClass | OverlapLimits


April

Profile Member List

This is the complete list of members for Profile, including all inherited members.

id | Profile
info() | Profile
isPredefined | Profile
isSupported | Profile
name | Profile
settings | Profile
setValueById([in] uint32 settingId,[in] uint32 value) | Profile
type | Profile
verClass | Profile


April

ProfileManager Member List

This is the complete list of members for ProfileManager, including all inherited members.

applyDisplayProfiles([in]string prefix) | ProfileManager
currentProfile3D | ProfileManager
defaultProfile3D | ProfileManager
info() | ProfileManager
loadDesktopProfile([in]string name) | ProfileManager
lockDesktopProfile([in]string name,[in]uint32 lock) | ProfileManager
restoreDefaults3D() | ProfileManager
saveDisplayProfiles([in]string prefix) | ProfileManager
setCurrentProfile3D([in]string name) | ProfileManager
setVSync([in, ValueMap{"0","1","2","3","4"}, Values{"Passive","Off","On","Adaptive","Adaptive half"}] uint32 vsyncMode) | ProfileManager
verClass | ProfileManager


April

Setting Member List

This is the complete list of members for Setting, including all inherited members.

id | Setting
info() | Setting
type | Setting
value | Setting
verClass | Setting


April

System Member List

This is the complete list of members for System, including all inherited members.

info() | System
nViewState | System
setnViewState([in, ValueMap{"0","1"}, Values{"Disable","Enable"}] uint32 state) | System
verClass | System
verDisplayDriver | System
verGSyncFirmware | System
verNVWMI | System
verSDICaptureDriver | System
verSDICaptureFirmware | System
verSDIOutputDriver | System
verSDIOutputFirmware | System
verVBIOS | System


April

ThermalEvent Member List

This is the complete list of members for ThermalEvent, including all inherited members.

handleGpu | ThermalEvent
probeIndex | ThermalEvent
thermalLevel | ThermalEvent


April

ThermalProbe Member List

This is the complete list of members for ThermalProbe, including all inherited members.

handle | ThermalProbe
info() | ThermalProbe
temperature | ThermalProbe
thermalLevel | ThermalProbe
ver | ThermalProbe


April

Version Member List

This is the complete list of members for Version, including all inherited members.

orderedValue | Version
strValue | Version
value | Version


April
  • All
  • Functions
  • Variables
  • a
  • c
  • i
  • l
  • r
  • s

- a -

  • applyDisplayProfiles() : ProfileManager

- c -

  • createDisplayGridById() : DisplayManager
  • createDisplayGridByName() : DisplayManager
  • createDisplayGridByRef() : DisplayManager

- i -

  • info() : Gpu , Profile , DisplayGridInfo , Setting , ProfileManager , ThermalProbe , Cooler , DisplayMode , Display , DisplayGrid , OverlapLimits , DisplayManager , Board , System

- l -

  • loadDesktopProfile() : ProfileManager
  • lockDesktopProfile() : ProfileManager

- r -

  • restoreDefaults3D() : ProfileManager
  • restoreNativeDisplayMode() : Display

- s -

  • saveDisplayProfiles() : ProfileManager
  • setCurrentProfile3D() : ProfileManager
  • setDisplayMode() : DisplayGrid
  • setDisplayModeById() : DisplayGrid
  • setDisplayModeByRef() : DisplayGrid
  • setEDID() : Display
  • setEDIDAll() : DisplayManager
  • setnViewState() : System
  • setOverlapCol() : DisplayGrid
  • setOverlapRow() : DisplayGrid
  • setOverlaps() : DisplayGrid
  • setScaling() : Display
  • setScalingAll() : DisplayManager
  • setValueById() : Profile
  • setVSync() : ProfileManager


April
  • All
  • Functions
  • Variables
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • colorDepth : DisplayMode
  • cols : DisplayGrid , DisplayGridInfo
  • coolerIndex : CoolerEvent
  • coolerLevel : Cooler , CoolerEvent
  • coolers : Board , Gpu
  • coreCount : Gpu
  • count : NamedObject
  • currentProfile3D : ProfileManager

- d -

  • defaultProfile3D : ProfileManager
  • displayIds : DisplayGridInfo
  • displayModeNative : Display
  • displayModePhysical : DisplayGrid
  • displayModes : DisplayGrid , Display
  • displayModeVirtual : DisplayGrid
  • displays : DisplayGrid

- e -

  • EDID : Display
  • EDIDSize : Display

- f -

  • fanSpeed : Cooler

- g -

  • gpuConnectorType : Display
  • gpuCoreClockCurrent : Gpu
  • gpus : DisplayGrid , Board
  • grid : DisplayProfile

- h -

  • handle : Gpu , Cooler , ThermalProbe
  • handleGpu : ThermalEvent , CoolerEvent
  • height : DisplayMode

- i -

  • id : NamedObject , OverlapLimits , Setting , DisplayGridInfo , Profile , DisplayMode
  • isActive : Display
  • isPredefined : Profile
  • isSupported : Profile

- m -

  • make : Display
  • maxOverlapCol : OverlapLimits
  • maxOverlapRow : OverlapLimits
  • maxTotalCol : OverlapLimits
  • maxTotalRow : OverlapLimits
  • memoryBusWidth : Gpu
  • memoryClockCurrent : Gpu
  • memorySizeAvailable : Gpu
  • memorySizePhysical : Gpu
  • memorySizeVirtual : Gpu
  • memoryType : Gpu
  • minOverlapCol : OverlapLimits
  • minOverlapRow : OverlapLimits
  • minTotalCol : OverlapLimits
  • minTotalRow : OverlapLimits
  • model : Display

- n -

  • name : NamedObject , Profile
  • nViewState : System

- o -

  • orderedValue : Version
  • ordinal : NamedObject
  • overlapCols : DisplayGrid
  • overlapLimits : DisplayGrid
  • overlapRows : DisplayGrid

- p -

  • percentCoolerRate : Cooler
  • positionCol : DisplayGrid
  • positionRow : DisplayGrid
  • probeIndex : ThermalEvent
  • productName : Gpu
  • productType : Gpu

- r -

  • refreshRate : DisplayMode
  • rows : DisplayGridInfo , DisplayGrid

- s -

  • scaling : Display
  • settings : Profile
  • strValue : Version

- t -

  • temperature : ThermalProbe
  • thermalLevel : ThermalProbe , ThermalEvent
  • thermalProbes : Board , Gpu
  • type : Setting , Profile

- u -

  • uname : NamedObject
  • unames : DisplayGridInfo

- v -

  • value : Version , Setting
  • ver : Cooler , ThermalProbe , NamedObject
  • verClass : OverlapLimits , DisplayMode , ProfileManager , Setting , System , DisplayGridInfo , Profile , DisplayManager
  • verDisplayDriver : System
  • verFirmware : Display
  • verGSyncFirmware : System
  • verNVWMI : System
  • verSDICaptureDriver : System
  • verSDICaptureFirmware : System
  • verSDIOutputDriver : System
  • verSDIOutputFirmware : System
  • verVBIOS : Gpu , System

- w -

  • width : DisplayMode


April

Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:

o * Cooler

o * CoolerEvent

o * DisplayGridInfo

o * DisplayManager

o * DisplayMode

o + NamedObject

| o * Board

| o * Display

| o * DisplayGrid

| \ * Gpu

o * OverlapLimits

o + Profile

| \ * DisplayProfile

o * ProfileManager

o * Setting

o * System

o * ThermalEvent

o * ThermalProbe

\ * Version


April

Related Pages

Here is a list of all related documentation pages:
  • Legal Notice
  • Cooler and Thermal Events
  • Using NVWMI
  • NVIDIA Performance Counters
  • Logging and tracing NVWMI activity
  • Using NVWMI with the WMIC tool
  • Using NVWMI with the PowerShell